FAQs Técnicas

Realizar una pregunta

SoMachine v4.1 SP2 - Error al conectar con el autómata "El sistema de destino seleccionado no coincide con el dispositivo conectado"

Cuando en SoMachine v4.1 SP2 aparece el error "El sistema de destino seleccionado no coincide con el dispositivo conectado" al conectar con el autómata, esto indica que la versión de firmware del plc y la versión de dispositivo seleccionada en el software no son compatibles.

Como podemos comprobar en la siguiente imagen, el dispositivo seleccionado y el conectado tienen la misma referencia, pero existe una incompatibildad de versiones que impide la conexión:


Existen dos soluciones:
1- Actualizar el firmware del autómata
La versión mínima de firmware compatible con las versiones de dispositivo de SoMachine v4.1 SP2 son:
  Versión de dispositivo Versión de firmware
M241 4.0.3.8 4.0.3.18
M251 4.0.3.9 4.0.3.18
M251 EIP Scanner 4.0.3.10 4.0.4.14

El firmware se puedeactualizar mediante el Controller Assitant conectando al dispositivo o mediante un tarjeta SD

2- Degradar la versión de dispositivo del controlador seleccionado en SoMachine
Se deben seguir los siguientes pasos:
- My controller -->Actualizar dispositivo...

- Marcar el CheckBox "Mostrar todas las versiones"
- Seleccionar una versión de dispositvo menor, como por ejemplo la v4.0.2.20
¿Ha sido útil?
¿Qué podemos hacer para mejorar la información?