FAQs Técnicas

Realizar una pregunta

Aparece el error "Los Bits extraídos no son compatibles con este tipo de datos" al compilar un proyecto con cierta versión de Unity pero no al hacerlo con otra versión posterior.

En la aplicación referida, el error "Los Bits extraídos no son compatibles con este tipo de datos" suele aparecer siempre asignado a una operación en la que se ha programado un bit extraído de una variable de tipo BYTE.

A partir de la versión v5.0 de Unity Pro, al acceder al menú [Herramientas > Ajustes de Proyecto > Variables], se puede encontrar la opción "Permitir la extracción de bits de INT, WORD y BYTE".
En versiones anteriores de Unity Pro (v4.1 y anteriores), la misma opción indica "Permitir la extracción de bits de INT y WORD", con lo que se concluye que en los proyectos creados con dichas versiones no se permitía la extracción de bits de registros de tipo BYTE.
¿Ha sido útil?
¿Qué podemos hacer para mejorar la información?